在eclipse上配置tomcat(包括解决找不到server,配置8.0以上版本)

2021-09-26

下载安装eclipse
普通eclipse最多只支持到tomcat v 7,要想使用8以上的tomcat,就需要下载最新版本的Eclipse IDE,安装时 选择 Eclipse IDE for Enterprice Java Developers
eclipse下载链接:https://www.eclipse.org/downloads/
运行安装包后选择想要下载的类型。

 

 

添加server runtime environment

  1.打开eclipse,点击Window --> preference --> 搜索server, 如果能找到,就接着选择runtime environments

  2.如果没有server,就点击Help --> Install New Software。点击add后,Name:Kepler 。Location:http://download.eclipse.org/releases/kepler

        

     加载完毕之后,在Web,XML, Java EE and OSGi Enterprise Development里选择JST Server AdaptersExtensions,下载完重启eclipse就可以找到server了。

 

  3.在runtime environments里 点击 add,选择需要的tomcat版本。点击next。

      

 

 

        

   有的eclipse这里最高只能找到7,要想用更高版本的,最直接的方法就是下Eclipse IDE for Enterprice Java Developers。
   点击next之后,选择你电脑里对应版本tomcat安装的路径。JRE可以选择eclipse自带的,也可以选你电脑里装的。点击finish完成添加。
   

 

 

 

  4.点击 close and apply

  5.点击Window --> show view --> server 。如果没有server,点击 other,搜索server,再双击打开server面板。

  6.点击click this to create a new server,增添server实例。

  7.选择对应版本的tomcat后,直接finish

   

 

 

     

 

 

  8.双击这个实例,根据你电脑上tomcat的安装路径修改server path 和 deploy path。修改完ctrl+s保存。

    

 

 

 

  9.右键server实例,运行tomcat

   

 

 

  10.如果没有报错,出现这些东西就说明大功告成了!!

    

 

 

 

  11.如果报错了,例如**-Djava.endorsed.dirs=D:\apache-tomcat\apache-tomcat-7.0.99\endorsed is not supported Endorsed standards**, 就说明你的jdk版本不支持你的 tomcat版本,需要降低jdk版本或下一个更高版本的tomcat

 


 

更多精彩内容  请扫码关注个人公众号带你成为IT精英


 

——  ——  ——  ——  —  END  ——  ——  ——  ——  ———— 

         欢迎扫码关注我的公众号

          爬神养成记